Заработай на задачках

При выходе новой версии Adobe Flash Player браузер Firefox не отображает сразу flash-контент. Требует ручного разрешение на его отображение на каждом конкретном сайте. Если такое сообщение появилось, то пора обновить Adobe Flash Player в Debian.

Обновление flashplugin-nonfree

Сравнить текущую версию плагина с актуальной можно с помощью команды:

# sudo update-flashplugin-nonfree --status

Для получение свежей версии должно быть достаточно ввести в терминал:

# sudo update-flashplugin-nonfree --install

Однако это не всегда помогает и плагин не обновляется.

Ручное обновление Adobe Flash Player в Debian

Даже после команды на установку у меня не обновлялся флеш-плагин.
$ sudo update-flashplugin-nonfree --status Flash Player version installed on this system : 11.2.202.616 Flash Player version available on upstream site: 11.2.202.621

Дело в том, что в репозиториях еще не было свежей версии:
Адрес: https://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.11.2.202.621.sha512.i386.pgp.asc [переход] --2016-06-09 15:22:51-- https://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.11.2.202.621.sha512.i386.pgp.asc Подключение к people.debian.org (people.debian.org)|5.153.231.30|:443... соединение установлено. HTTP-запрос отправлен. Ожидание ответа... 404 Not Found 2016-06-09 15:22:51 ОШИБКА 404: Not Found.

Если актуальной версии флеш-плеера еще нет в репозитории Debian, то можно пойти другим путём:

  1. Качаем пакет tar.gz с официально сайта adobe. В данном случае версию 11.2.202.621.
  2. Распаковываем его:
    $ tar -xvf install_flash_player_11_linux.i386.tar.gz
  3. Копируем библиотеку, содержащую плагин в систему:
    # cp libflashplayer.so /usr/lib/flashplugin-nonfree/

Всё прошло успешно:
# update-flashplugin-nonfree --status Flash Player version installed on this system : 11.2.202.621 Flash Player version available on upstream site: 11.2.202.621

Обновление flashplugin-nonfree в Debian: 3 комментария

  1. Kostya on 31.10.2016 at 00:15 пишет:

    Бальшущее спасибо! Все сайты облазил нигде не нашел как доработать обновление (вроде показывает плагин установлен, а мозила ругается) вы спасли меня!

  2. гость on 20.02.2017 at 14:48 пишет:

    И не забываем сделать симлинк на /usr/lib/adobe-flashplugin/libflashplayer.so
    иначе лиса будет юзать устаревший плагин

Я буду очень рад комментарию!

Не переживайте, e-mail нигде не отображается. Обязательные поля помечены *

Навигация по записям