Заработай на задачках

Первым делом настроим интернет, а точнее гостя, чтобы качать пакеты с гостевого репазитория…

1. Модем должен быть в режиме роутера и на нем гость, если нет, то обязательно переведите его в этот режим… ( Есть много причин по которым нужно это сделать).

2 Открываем /etc/rc.conf. Где раздел про сеть должно быть так:

# Use ‘ifconfig -a’ or ‘ls /sys/class/net/’ to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   – prefix an entry in INTERFACES with a ! to disable it
#   – no hyphens in your interface names – Bash doesn’t like it
#
# DHCP:     Set your interface to “dhcp” (eth0=”dhcp”)
# Wireless: See network profiles below
#
eth0=”eth0 192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.255″
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   – prefix an entry in ROUTES with a ! to disable it
#
gateway=”default gw 192.168.1.1″
ROUTES=(gateway)

3. Настроим DNS, открываем файл /etc/resolv.conf

Он должен принять вид (Гом. обл.):

nameserver 82.209.213.60
nameserver 193.232.248.2

Вот и все, интернет настроен :) Можно перейти к установки пакетов, каких? Расскажу в следуещем посте…

Настроим интернет в archlinux…: 8 комментариев

  1. forvard11 on 29.07.2009 at 16:18 пишет:

    Привет! Все кто читает этот блог – С Днем Примерения и согласия!

  2. espectro92 on 30.07.2009 at 11:33 пишет:

    Не знаю как остальным, а мне понравилось.

  3. forvard11 on 30.07.2009 at 16:33 пишет:

    Красиво написано, мне понравилось.

  4. forvard11 on 30.07.2009 at 16:58 пишет:

    На Ваш блог знакомый в аську ссылку кинул. Оказалось, что не зря Понравилось. Тепрь постоянно читать буду

  5. winternight on 19.03.2010 at 23:07 пишет:

    У меня так получается…
    # ping -c 3 google.com
    PING google.com (74.125.87.99) 56(84) bytes of data.
    From lo-router5400-4.vitebsk.by (194.158.203.234) icmp_seq=1 Packet filtered
    From lo-router5400-4.vitebsk.by (194.158.203.234) icmp_seq=2 Packet filtered

    — google.com ping statistics —
    3 packets transmitted, 0 received, +2 errors, 100% packet loss, time 2003ms

    лечу посредством route add default dev ppp0

  6. Возможно проблема с разными адресами сетевой карты/модема.

  7. winternight on 21.03.2010 at 01:11 пишет:

    описанная ситуация это и известная проблема rp-pppoe и починили ее только в дебиане (об этом написно на русском форуме арча) там же есть и следующий рецепт: Сделал на маршрут 192.168.1.1 metric 100 и в /etc/ppp/peers/pppoe закоментил defaultroute. С раскоментированной строчкой после опускания/поднятия pppoe инет опять ломился через eth0 , закоментировал defaultroute и всё заработало.
    У иностаранцев соединение поднимается на модеме, а в рунете об описанной проблеме есть упоминания.

  8. winternight on 21.03.2010 at 01:13 пишет:

    а еще у меня eth0=”dhcp” …

Я буду очень рад комментарию!

Не переживайте, e-mail нигде не отображается. Обязательные поля помечены *

Навигация по записям